FANDOM


What are the minimum & recommended system requirements for each expansion?


Labyrinth of the Minotaur

Minimum

  • Pentium 4 2.0 GHz or equivalent
  • 512 MB RAM
  • 3.5 GB free hard drive space
  • Compatible 3D acceleration card with 64 MB video RAM
  • Directx 9.0c or later
  • Shader 1.1 or higher
  • Internet Connection Required

Recommended

  • Pentium 4 3.0 GHz or equivalent
  • 1 GB RAM
  • 256 MB ATI X800 or Nvidia GeForce 6800 series or higher
  • Direct X 9.0c or later
  • Shader 2.X or greater support

Darkness Rising

Minimum

  • Pentium III 1.4GHz or AMD equivalent
  • 512 MB RAM
  • Requires compatible 3D Acceleration card with 64 MB Video RAM
  • DirectX 9.0 or later
  • Internet Connection Required

Recommended

  • Pentium 4 2.4GHz or AMD equivalent
  • 1 GB RAM
  • Compatible 3D Acceleration card with 128 MB Video RAM
  • DirectX 9.0 or later
  • Shader 2.X or greater support
  • Internet Connection Required

Catacombs

Minimum

  • Pentium III 1.4GHz or AMD equivalent
  • 512 MB RAM
  • Requires compatible 3D Acceleration card with 64 MB Video RAM
  • DirectX 9.0 or later
  • Internet Connection Required

Recommended

  • Pentium 4 2.4GHz or AMD equivalent
  • 1 GB RAM
  • Compatible 3D Acceleration card with 128 MB Video RAM
  • DirectX 9.0 or later
  • Shader 2.X or greater support

Trials of Atlantis

Minimum

  • Pentium III 1.4GHz or AMD equivalent
  • 384 MB RAM
  • Requires compatible 3D Acceleration card with 32 MB Video RAM
  • DirectX 9 or later
  • Internet Connection Required

Recommended

  • Pentium 4 2GHz or AMD equivalent
  • 512 MB RAM
  • NVidia GeForce 4 Ti series 3D video card with 64 MB Video RAM
  • DirectX 9 or later
  • Internet Connection Required

Shrouded Isles

Minimum

  • O/S: Windows 98/ME/XP (Windows 95/NT not supported)
  • DirectX 8.0 or later installed.
  • CPU: Pentium III 1.4Ghz or AMD Athlon equivalent
  • RAM: 256MB RAM
  • Video: Requires compatible 3D-Acceleration Card with 32MB Video RAM
  • Internet Connection: An Internet connection is required

Recommended

  • O/S: Windows 98/ME/XP (Windows 95/NT not supported)
  • DirectX 8.0 or later installed.
  • CPU: Pentium 4 1.4Ghz or better
  • RAM: 384MB+ RAM
  • Video: NVIDIA GeForce 4 Ti series 3D Video Card with 64MB+ Video RAM or equivalent
  • Internet Connection: An Internet connection is required

Please note, there may be other factors that could hinder game performance. Please be sure to search support.darkageofcamelot.com for various troubleshooting topics.

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.